Ignatius and the Princess III(母函数或动态规划)

  HDOJ1028:


    

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 

//此体可以看成是分苹果的特殊情况,即把n个苹果放入n个盘中;
//不过需要开辟一个dp数组保存计算值,避免重复计算超时;
#include<stdio.h>	
#include<string.h>
int dp[130][130];
int apple(int a,int b)
{
	if(dp[a][b]!=-1)
		return dp[a][b];
	if(a==0||b==1)
		dp[a][b]=1;
	else
	{
		if(a<b)
			dp[a][b]=apple(a,a);
		else
			dp[a][b]=apple(a,b-1)+apple(a-b,b);
	}
	return dp[a][b];
}

int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		memset(dp,-1,sizeof(dp));
		printf("%d\n",apple(t,t));
	}
	return 0;
}


//母函数求解;
#include <iostream>
using namespace std;

int main()
{
    int n;
    int c1[130],c2[130];
    //c1数组存储最终结果,c2存储中间量;
    while(cin>>n)
    {
        for(int i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(int i=2;i<=n;i++)//i是第i个表达式;
        {
            for(int j=0;j<=n;j++)//j是第一个表达式中的取0,1...n;
                for(int k=0;k+j<=n;k+=i)//k是第i个表达式中的取0,i,2*i,3*i...;
                    c2[k+j]+=c1[j];
            for(int j=0;j<=n;j++)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        cout<<c1[n]<<endl;
    }
    return 0;
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值