传送门:POJ3264
描述:
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 48161 | Accepted: 22588 | |
Case Time Limit: 2000MS |
Description
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Sample Input
6 3 1 7 3 4 2 5 1 5 4 6 2 2
Sample Output
6 3 0
Source
思路:使用RMQ算法,分别计算某个区间上的最小值和最大值,做差即可
RMQ介绍见Here
当然也可以用线段树
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include<cmath>
#define pr(x) cout << #x << "= " << x << " " ;
#define pl(x) cout << #x << "= " << x << endl;
#define ll __int64
using namespace std;
template<class T> void read(T&num) {
char CH; bool F=false;
for(CH=getchar();CH<'0'||CH>'9';F= CH=='-',CH=getchar());
for(num=0;CH>='0'&&CH<='9';num=num*10+CH-'0',CH=getchar());
F && (num=-num);
}
const int N=5e4+10;
int n,q;
int a[N];
int mn[N][25],mx[N][25];
int rmq_init(){
for(int i=1; i<=n; i++)mx[i][0]=a[i],mn[i][0]=a[i];
for(int j=1; (1<<j)<=n; j++)
for(int i=1; i+(1<<j)-1<=n; i++){
mx[i][j]=max(mx[i][j-1], mx[i+(1<<(j-1))][j-1]);
mn[i][j]=min(mn[i][j-1], mn[i+(1<<(j-1))][j-1]);
}
}
int rmq(int l,int r){
int k=(int)(log(r-l+1.0)/log(2.0));
return (max(mx[l][k], mx[r-(1<<k)+1][k])-min(mn[l][k], mn[r-(1<<k)+1][k]));
}
int main(){
#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
while(~scanf("%d%d",&n,&q)){
for(int i=1; i<=n; i++)read(a[i]);
rmq_init();
int l,r;
while(q--){
read(l);read(r);
printf("%d\n", rmq(l, r));
}
}
return 0;
}