hdu1715 java解大菲波数

大菲波数

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9224    Accepted Submission(s): 3133


Problem Description
Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。
 

Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。
 

Output
输出为N行,每行为对应的f(Pi)。
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
1 1 2 3 5
 
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String []args)throws Exception{
		Scanner cin = new Scanner(System.in);
		int t = cin.nextInt();
		while(t--!=0){
		String a=cin.next();
		int n = Integer.parseInt(a);
		System.out.println(fibo(n));
		}
		cin.close();
	}
	public static BigInteger fibo(int n){
		BigInteger f = new BigInteger("1");
		BigInteger s = new BigInteger("2");
		if(n==1||n==2)
			return f;
		if(n==3)
			return s;
		int sum=3;
		while(true){
			sum++;
			BigInteger tem = f;
			f=s;
			s=s.add(tem);
			if(sum==n)
				return s;
		}
	}
}
//用java结题的时候要注意,类要命名为Main哦
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

果冻虾仁

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值