Yuanfang,what do you think ?

Yuanfang,what do you think ?

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Yuanfang is the best student in the class. Every time when the teacher comes up with a hard problem and it seems no student can solve it, He always says: "Yuanfang , what do you think?".
       One day, They had a math class,The teacher said:”Let’s calculate the sum of 1^2+2^2…+n^2,Yuanfang, what do you think?"
       Yuanfang wanted to solve this problem quickly. So he came to you, the only programmer he knows, for help.
       You should write a program to calculate SUM(n)=1^2+2^2…+n^2 to help him.

输入

 There are several test cases.

Each case has an integer n (1≤n≤1000) in a line.

输出

 For each test case,output one line containing a result SUM(n).

示例输入

110

示例输出

1385

提示

 

来源

 

示例程序

 
#include<stdio.h>  
int main()  
{  
    int i,n,m;  
    while(scanf("%d",&n)!=EOF)  
    {  
        m=0;  
        for(i=1;i<=n;i++)  
        {  
            m+=i*i;  
        }  
        printf("%d\n",m);  
    }  
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值