uva156

刷紫书,看完了STL的用法之后重现了一遍,和书里面的代码基本一样的。该题最重要的是如何把单词标准化,归一到同一个标准下进行判断。很显然,单词是否能够重排成段落中的其他单词,只需要看这两个单词在同一个排列熟悉下面是否一样即可,用sort排序,然后用map来进行统计即可,当对应键值的统计数为1则代表该单词不能重排成段落中的另一个。
题目如下
Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different
orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this
attribute, no matter how you rearrange their letters, you cannot form another word. Such words are
called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think
that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible
domain would be the entire English language, but this could lead to some problems. One could restrict
the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the
same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative
ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be
“rearranged” at all. The dictionary will contain no more than 1000 words.
Input
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any
number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken
across lines. Spaces may appear freely around words, and at least one space separates multiple words
on the same line. Note that words that contain the same letters but of differing case are considered to
be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line
consisting of a single ‘#’.
Output
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram
in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always
be at least one relative ananagram.
Sample Input
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
#
Sample Output
Disk
NotE
derail
drIed
eye
ladder
soon

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
//标准化
string stand_norm(const string& str)
{
    string temp = str;

    for (int i = 0; i < temp.length(); i++)
        temp[i] = tolower(temp[i]);
    sort(temp.begin(), temp.end());
    return temp;
}
map<string, int> Word_Cnt;
vector<string> Word_Orig;
int main()
{
    string s;

    while (cin >> s)
    {
        if (s[0] == '#') break;
        Word_Orig.push_back(s);
        string judgestr = stand_norm(s);
        if (!Word_Cnt.count(judgestr)) 
            Word_Cnt[judgestr] = 0;
        Word_Cnt[judgestr]++; //等于1的就是不能ananagram的单词
    }
    vector<string> ans;

    for (int i = 0; i < Word_Orig.size(); i++)

    if (Word_Cnt[stand_norm(Word_Orig[i])] == 1) ans.push_back(Word_Orig[i]);

    sort(ans.begin(), ans.end());
    for (int i = 0; i < ans.size(); i++)
        cout << ans[i] << "\n";

    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值