PAT 1064. Complete Binary Search Tree (二叉树遍历)


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4


题意,给你n个结点,让你遍历构造一个完全二叉树,层次遍历。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int N = 1e3+100;
int a[N],c[N],n,k,d[N];
void dfs(int id)
{
	if(id>n) return ;
	dfs(id<<1);
	c[++k]=id;
	dfs(id<<1|1);
}
int main()
{
	int i,j;
	scanf("%d",&n);
	for(i=1;i<=n;i++) scanf("%d",&a[i]);
	sort(a+1,a+n+1);
	k=0;
	dfs(1);
	for(i=1;i<=n;i++) {
		d[c[i]]=a[i];
	}
	for(i=1;i<=n;i++) {
		if(i==1) printf("%d",d[i]);
		else printf(" %d",d[i]);
	}
	printf("\n");
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
下面是使用二叉链表存储结构实现的二叉树,并包含以上功能的代码实现: ```python class Node: def __init__(self, value): self.value = value self.left = None self.right = None class BinaryTree: def __init__(self): self.root = None def create_tree(self): """ 创建二叉树,输入节点的值,以'#'代表空节点 """ value = input("请输入节点的值:") if value == '#': return None node = Node(value) node.left = self.create_tree() node.right = self.create_tree() return node def preorder_traversal(self, node): """ 先序遍历二叉树,输出遍历结果 """ if node is None: return print(node.value, end=' ') self.preorder_traversal(node.left) self.preorder_traversal(node.right) def inorder_traversal(self, node): """ 中序遍历二叉树,输出遍历结果 """ if node is None: return self.inorder_traversal(node.left) print(node.value, end=' ') self.inorder_traversal(node.right) def postorder_traversal(self, node): """ 后序遍历二叉树,输出遍历结果 """ if node is None: return self.postorder_traversal(node.left) self.postorder_traversal(node.right) print(node.value, end=' ') def get_depth(self, node): """ 求二叉树深度,返回深度值 """ if node is None: return 0 left_depth = self.get_depth(node.left) right_depth = self.get_depth(node.right) return max(left_depth, right_depth) + 1 def get_leaf_count(self, node): """ 求二叉树叶子节点的个数,返回叶子节点数量 """ if node is None: return 0 if node.left is None and node.right is None: return 1 return self.get_leaf_count(node.left) + self.get_leaf_count(node.right) ``` 可以通过以下代码进行测试: ```python tree = BinaryTree() root = tree.create_tree() print("先序遍历结果:", end='') tree.preorder_traversal(root) print("\n中序遍历结果:", end='') tree.inorder_traversal(root) print("\n后序遍历结果:", end='') tree.postorder_traversal(root) print("\n二叉树深度:", tree.get_depth(root)) print("二叉树叶子节点数量:", tree.get_leaf_count(root)) ``` 其中,`create_tree()`方法会提示用户输入节点的值,当输入'#'时代表该节点为空节点。其他方法分别实现了先序、中序、后序遍历,以及求二叉树深度和叶子节点数量的功能。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值