贪心

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

题解:构建一个优先队列用来维护最优解就行了;

代码:

#include <iostream>
#include <algorithm>
#include <queue>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        priority_queue<int> pq;
        int m,n,i,j,k;
        int a[105][2050],b[2050];
        cin>>m>>n;
        
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&a[i][j]);
            }
            sort(a[i],a[i]+n);
        }

        for(i=0;i<n;i++)
            pq.push(a[0][i]);
        for(i=1;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                b[j]=pq.top();
                pq.pop();
            }
            for(j=0;j<n;j++)
            {
                for(k=n-1;k>=0;k--)
                {
                    if(j==0) pq.push(a[i][j]+b[k]);
                    else
                    {
                        if(pq.top()>a[i][j]+b[k]) //如果想加的和比 队列中的 最大值小,队顶删除,和进队列
                        {
                            pq.pop();
                            pq.push(a[i][j]+b[k]);
                        }
                        else break;//后面的相加会更大,直接跳出循环;
                    }
                }
            }
        }
        for(i=0;i<n;i++)
        {
            b[i]=pq.top();
            pq.pop();
        }
        cout<<b[n-1];
        for(i=n-2;i>=0;i--)
            cout<<" "<<b[i];
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值