Pairs Forming LCM

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

题解:欧拉筛维护素数表,然后 对 n 进行 素因数分解,然后计算就行了,

代码:

#include <iostream>
#include <cstring>

using namespace std;

typedef long long LL;
const int MAXN=10000000;
bool isprime[MAXN+1];
int prime[MAXN/10], tot; //防止MLE

void getPrime() {
    memset(isprime, true, sizeof(isprime));
    isprime[0] = isprime[1] = false;
    tot = 0;
    for(int i = 2; i < MAXN; i++) {
        if(isprime[i]) prime[tot++] = i;
        for(int j = 0; j < tot && prime[j] <= MAXN / i; j++) {
            isprime[i * prime[j]]=false;
            if(i % prime[j] == 0) break;
        }
    }
}//欧拉筛维护素数表;

LL factor[1000][2]; //factor[i][0]存底数,factor[i][1]存指数

int cnt;

void getFactors(LL n) {
    cnt = 0;
    for(int i = 0; i < tot && prime[i] <= n / prime[i]; i++) {
        if(n % prime[i] == 0) {
            factor[cnt][0] = prime[i];
            factor[cnt][1] = 0;
            while(n % prime[i] == 0) {
                factor[cnt][1]++;
                n /= prime[i];
            }
            cnt++;
        }
    }
    if(n != 1) {
        factor[cnt][0] = n;
        factor[cnt][1] = 1;
        cnt++;
    }
}//素因数分解

int main()
{
    getPrime();
    int T;
    cin>>T;
    for(int i=1;i<=T;i++)
    {
        LL n;
        cin>>n;
        getFactors(n);
        long long s=1;
        //cout<<cnt<<endl;
        for(int j=0;j<cnt;j++)
        {
            s=s*(2*factor[j][1]+1);
        }
        s=(s+1)/2;
        cout<<"Case "<<i<<": "<< s <<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值