PAT 1003 Emergency

题目

As an emergency rescue team leader of a city, you are given a special map of your country.
The map shows several scattered cities connected by some roads.
Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map.
When there is an emergency call to you from some other city,
your job is to lead your men to the place as quickly as possible,
and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1and C​2 the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1, c​2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1 to C​2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1 and C​2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

解答:

简单的说,就是只使用dfs来遍历整张图,从而获得最短路的条数和在最短路的条件下可以召集到的最多的人手 。当然直接dfs是有风险的,但是这道题的数据量告诉我们可以瞎搞,所以dfs加简单的剪枝就足以解决问题。
易错点:当最小路径发生变化之后,对于原来获得数据都要进行重新的统计。

代码:

#include<iostream>
#include<cstdio>
using namespace std;

int val[505][505]={0},vis[505]={0};
int c1,c2,n,m,rec[505],road=0,mins=0x7fffffff,maxs=0;

void dfs(int x,int res,int res1){
    if(res>mins) return;
    if(x==c2&&res<=mins) {//这个地方其实写的太啰嗦,可以合并掉,另外注意不要有多余的输出,血的教训!!!
        if(res<mins) maxs = res1;
        else maxs=(maxs<res1?res1:maxs);
        if(res<mins)road=1;
        else road++;
        mins=res;
        return;
    }
    for(int i=0;i<n;++i){
        if(!vis[i]&&val[x][i]){
            vis[i] = 1;
            dfs(i,res+val[x][i],res1+rec[i]);
            vis[i] = 0;
        }
    }
}

int main(){
    scanf("%d%d%d%d",&n,&m,&c1,&c2);
    for(int i=0;i<n;++i) scanf("%d",&rec[i]);
    for(int i=0;i<m;++i) {
        int f,t,v;
        scanf("%d%d%d",&f,&t,&v);
        val[t][f] = v;
        val[f][t] = v;
    }
    vis[c1] = 1;
    dfs(c1,0,rec[c1]);
    printf("%d %d\n",road,maxs);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值