HDU 3714 Error Curves(三分+模拟)

97 篇文章 0 订阅
10 篇文章 0 订阅

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties.

In order to test the algorithm's efficiency, she collects many datasets. What's more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data.

To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

Quadric Function

It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimal which related to multiple quadric functions.

The new function F(x) is defined as follow:

F(x) = max(Si(x))i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function.

Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n(n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000

题解:

比赛的一题。。但是之前没写过三分,就搜了博客学了下三分。

这题就是给了一堆一元二次方程,设F(x)为区间内每一个点处的各个方程中的最大值,求在[0,1000]区间内F(x)的最小值

思路就是每次取区间中点mid和中点与右边界(或者左边界)的中点midd,看F(x)在两点处的值,如果F(mid)>F(midd),就更新左边界为mid,否则更新右边界为midd,最后F(mid)就是答案

代码是照着别人打的:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<deque>
using namespace std;
#define eps 1e-15
double a[10005];
double b[10005];
double c[10005];
int n;
double fen(double x)//F(x)
{
    double t=a[0]*x*x+b[0]*x+c[0];
    for(int i=1;i<n;i++)
        t=max(t,a[i]*x*x+b[i]*x+c[i]);
    return t;
}
void solve()
{
    double l=0,r=1000,mid,midd,t1,t2;
    while(l+eps<r)
    {
        mid=(r+l)/2;
        midd=(mid+r)/2;//中点与右边界的中点
        t1=fen(mid);
        t2=fen(midd);
        if(t1>t2)//如果左边更大,更新左边界
            l=mid;
        else//否则更新右边界
            r=midd;
    }
    printf("%.4lf\n",fen(r));
}
int main()
{
    int test,i;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值