HDU2051&2031【进制转换】

49 篇文章 0 订阅
16 篇文章 0 订阅

2051:http://acm.hdu.edu.cn/showproblem.php?pid=2051


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 10 11

#include<iostream>
#include<stdlib.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<math.h>
#include<time.h>
using namespace std;
int main()
{
   int n,a[11]={0};
    while(cin>>n)
    {
        int i=0;
        while(n>=1&&n<1000)
        {
             a[i++]=n%2;
            n=n/2;
        }

        for(int j=i-1;j>=0;j--)
        {
            cout<<a[j];
        }
      cout<<endl;
    }
    return 0;

}



2031:

Problem Description

输入一个十进制数N,将它转换成R进制数输出。

Input

输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。

Output

为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。

Sample Input

7 2
23 12
-4 3

Sample Output

111
1B
-11

解题思路:

使用栈,因为有负数,所以符号单独输出。

代码:


#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

int main()
{
    char ch[10005];
    int n, m, count;
    while (~scanf("%d %d",&m,&n))
    {
        int f = 0;
        count = 0;
        memset(ch, NULL, sizeof(ch));
        if (m == 0)
        {
            cout << "0" << endl;
            continue;
        }
        if (m < 0)
        {
            f = 1;
            m = abs(m);
        }
        while (m)
        {
            ch[count++] = m%n;
            m /= n;
        }
        if (f)
            cout << "-";
        for (int i = count - 1; i >= 0; i--)
        {
            if (ch[i] >= 10)
            {
                ch[i] += 55;
                cout << ch[i];
            }
            else
                printf("%d", ch[i]);
        }
        cout << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值