Adjacent Bit Counts HDU - 3284 [DP]

Fighting!~~

Adjacent Bit Counts

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 497    Accepted Submission(s): 414


Problem Description
For a string of n bits x 1, x 2, x 3, …, x n, the adjacent bit count of the string ( AdjBC(x)) is given by

x1*x2 + x2*x3 + x3*x4 + … + xn-1*xn

which counts the number of times a 1 bit is adjacent to another 1 bit. For example:

AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0

Write a program which takes as input integers n and k and returns the number of bit strings x of n bits (out of 2 n) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting
AdjBC(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011
 

Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.
 

Output
For each data set there is one line of output. It contains the data set number followed by a single space, followed by the number of n-bit strings with adjacent bit count equal to k.
 

Sample Input
 
     
101 5 22 20 83 30 174 40 245 50 376 60 527 70 598 80 739 90 8410 100 90
 
Sample Output
 
     
1 62 634263 18612254 1682125015 448747646 1609167 229373088 991679 1547610 23076518
 

Source
 

Recommend
zhuweicong


题意:ans=sigma (x[i]*x[i-1]) 其中xi只能为0或者1,问长度为n,ans==k有多少种情况?

思路:
dp[n][k][num]代表以num为结尾,长度为n,和为k的方案数.那么很容易有如下状态转移方程
dp[n][k][1]=dp[n-1][k][0]+dp[n-1][k-1][1];
dp[n][k][0]=dp[n-1][k][1]+dp[n-1][k][0];

#include <stdio.h>
#include <iostream>
#include <string.h>
typedef long long ll;

using namespace std;

const int MAX_N=1e6+6;
int dp[105][105][2];

void init(){
    ///求解dp[2][1~105][1]//
    dp[2][1][1]=1,dp[2][0][1]=1;
    ///求解dp[2][1~105][0]//
    dp[2][1][0]=0,dp[2][0][0]=2;
    ///求解dp[2~105][0][1] 求解dp[2~105][0][0]  这两个值互相联系,要一起求
    for(int i=3;i<=104;i++) dp[i][0][1]=dp[i-1][0][0],dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];
    for(int n=3;n<=104;n++){
        for(int k=1;k<=104;k++){
            dp[n][k][1]=dp[n-1][k][0]+dp[n-1][k-1][1];
            dp[n][k][0]=dp[n-1][k][1]+dp[n-1][k][0];
        }
    }
}

int main(void){
   init();
   int T;
   cin >>T;
   while(T--){
        int num,x,y;
        scanf("%d%d%d",&num,&x,&y);
        printf("%d %d\n",num,dp[x][y][1]+dp[x][y][0]);
   }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值