Children’s Queue HDU1297

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like 
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM 
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children? 
InputThere are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)OutputFor each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.Sample Input
1
2
3
Sample Output
1
2
4

a[i][j]中的i代表第n个,j代表第n个数的第j位


#include <stdio.h>
int a[1001][300];
void fun(){
    int i,j,t;
    a[1][1]=1;
    a[2][1]=2;
    a[3][1]=4;
    a[4][1]=7;
    for(i=5;i<=1000;i++){
        int pu=0;
        for(j=1;j<300;j++){
            t=a[i-4][j]+a[i-2][j]+a[i-1][j]+pu;
            a[i][j]=t%10;
            pu=t/10;    //该位够十以后进到下一位
                       //此处还有一个作用,就是把没有数的都等于0
        }
    }
}

int main(void)
{
    int n,i;
    fun();
    while(scanf("%d",&n)!=EOF){
        i=299;
        while(i>0&&!a[n][i]){   //i>0并且a[n][i]=0,i--是为了找到a[n]的最后一位
            i--;
        }
        for(;i>0;i--)
            printf("%d",a[n][i]);
        printf("\n");


    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值