POJ1852 UVA10714 ZOJ2376 Ants

Ants

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions:24497 Accepted: 9798

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

Waterloo local 2004.09.19

问题简述;

横杆上有n个蚂蚁,蚂蚁在横杆上运动,两只蚂蚁相遇后会调转方向,蚂蚁的速度都为1,输入中会给两个数据,横杆的长度和蚂蚁数量n,n个蚂蚁的初始位置……,要求输出蚂蚁从横杆上掉下的最早时间和最晚时间(自己寻找合适的方向) 

分析:

问题的关键是想到可以把蚂蚁“相遇后掉头”的问题等价为“相遇后方向不变 互不干扰”

还要想到max,min函数来简化程序

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main(){
   int t;
   scanf("%d",&t);
   while(t--){
        int l,n;
        int minn=0;
        int maxn=0;
        scanf("%d%d",&l,&n);
        int val;
        for(int i=0;i<n;i++){
            scanf("%d",&val);
            minn=max(minn,min(val,l-val));
            maxn=max(maxn,max(val,l-val));
        }
   printf("%d %d\n",minn,maxn);

   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值