1071 Speech Patterns (25分)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?
Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.
Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题意:输入一串字符串,统计当中出现次数最多单词(单词只能有大小写字母以及阿拉伯数字组成,不分大小写);
思路:可以很清楚地判断出需要使用map<string,int>,但是要做到跳过非法字符,以及不要使用cin,因为cin是以空格,换行作为结束标志,需要使用getline(),以换行作为结束标志;大小写的转换也是必须要考虑的问题;

AC

#include<iostream>
#include<string>
#include<map>
using namespace std;
bool check(char c){//判断合法字符
	if(c>='0'&&c<='9')return true;
	if(c>='A'&&c<='Z')return true;
	if(c>='a'&&c<='z')return true;
	return false;
}
int main(){
	map<string,int>mp;
	map<string,int>::iterator it;
	string str;
	getline(cin,str);//读入字符串
	int i=0;
	while(i<str.size()){
		string word;
		while(i<str.size()&&check(str[i])==true){
            if(str[i]>='A'&&str[i]<='Z'){//大小写转换
				str[i]=str[i]+32;
			}
			word=word+str[i];
			i++;
		}
		if(word!=""){//防止开头即为非法字符
			if(mp.find(word)!=mp.end())mp[word]++;
			else mp[word]=1;
		}
		while(i<str.size()&&check(str[i])==false){//跳过非法字符
			i++;
		}
	}
	int max=0;
	string key;
	for(it=mp.begin();it!=mp.end();it++){
		if(it->second>max){
			max=it->second;
			key=it->first;
		}
	}
	printf("%s %d\n",key.c_str(),max);//c_str转化格式
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值