Catch That Cow

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示


题意:有一个农民和一头牛,他们在一个数轴上,牛在k位置保持不动,
农户开始时在n位置。设农户当前在M位置,每次移动时有三种选择:
1.移动到M-1;2.移动到M+1位置;3.移动到M*2的位置。
问最少移动多少次可以移动到牛所在的位置。所以可以用广搜
来搜索这三个状态,直到搜索到牛所在的位置。
#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
#define max 200001
using namespace std;
struct node
{
    int step;//查找的步数;
    int x;//记录位置;
}a,b;
int v[200001];//标记数组;
int c(int x)
{
    if(x<0||x>=max||v[x])//查找不到。
        return 0;
    return 1;
}
int n,m;
int bfs(int n)
{
    queue<node>q;//结构体进队;
    a.x=n;//农户开始的位置;
    a.step=0;
    v[a.x]=1;
    q.push(a);
    while(!q.empty())
    {
        a=q.front();
        q.pop();
        if(a.x==m)//找到牛的位置;
            return a.step;
        b=a;
        if(c(a.x+1))//向前一步走;
        {
            b.x=a.x+1;
            b.step=a.step+1;
            v[a.x+1]=1;//标记走过;
            q.push(b);
        }
        if(c(a.x-1))//向后一步走;
        {
            b.x=a.x-1;
            b.step=a.step+1;
            v[a.x-1]=1;
            q.push(b);
        }
        if(c(a.x*2))
        {
            b.x=a.x*2;
            b.step=a.step+1;
            v[a.x*2]=1;
            q.push(b);
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(v,0,sizeof(v));//初始化;
        printf("%d\n",bfs(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值