【算法练习】01背包 -hdu2602-bone collector

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602

最简单常规的01背包。

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

1 5 10 1 2 3 4 5 5 4 3 2 1

 

 

Sample Output

 

14

 

#include<iostream>
#include<math.h>
#include<string.h>
using namespace std;

	int Vmat[1000][1000];
	int dp[1000];
int main(){
	int T;
	int N[1000]={0};
    int V[1000]={0};

	cin>>T;
	
	while(T--){
		int nNum;cin>>nNum;
		int nVol;cin>>nVol;
		
		
		
		for(int i=1;i<=nNum;i++){
			cin>>N[i];
		} 
		
		for(int i=1;i<=nNum;i++){
			cin>>V[i]; 
		} 
		
		
		for(int i=0;i<=nNum;i++){
			Vmat[i][0]=0;
		}
		for(int i=0;i<=nVol;i++){
			Vmat[0][i]=0;
		}
		
		memset(dp,0,sizeof(dp));
		
		for(int i=1;i<=nNum;i++){
			for(int j=nVol;j>=0;j--){
				if(V[i]<=j){
					dp[j]=max(dp[j],dp[j-V[i]]+N[i]);
				}
			}
		}
		
		cout<<" 1D matric:dp="<<dp[nVol]<<endl;
		//一维数组保存dp
		
		for(int i=1;i<=nNum;i++){
			for(int j=0;j<=nVol;j++){
				Vmat[i][j]=Vmat[i-1][j];
				if(V[i]<=j){
					Vmat[i][j]=max(Vmat[i][j],Vmat[i-1][j-V[i]]+N[i]);
				}
			}
		}
		
		cout<<" 2D matric:dp="<<Vmat[nNum][nVol]<<endl;
        //二维数组保存dp
	}
	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值