HUD6318 Swaps and Inversions

Problem Description
Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair 
(i,j)which 1≤i<j≤nand ai>aj. 
Input
There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000
, numbers in the sequence are in [−109,109]. There're 10 testcases.
 Output
For every test case, a single integer representing minimum money to pay.


Sample Input
3 233 666
1 2 3
3 1 666
3 2 1


Sample Output
0
3

题解:把逆序的序列通过交换相邻两个数转换成正序的数列需要的次数=该序列的逆序数
所以设逆序数cnt
求min(cnt*X,cnt*Y);
怎么求逆序数:用树状数组,建立一个结构体存数值x和下标i,按数值sort排序,从最大的x开始标记,利用query查找1-i的和,即从1-i一共有多少个标记的数,对于第i大的数,query返回的就是比当前i大的标记过的数的个数,即i的逆序数

序列的逆序数等于所有数的逆序数之和

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string>
#include<string.h>
#define ll long long
using namespace std;

int n,X,Y;

struct node
{
    int i,x;
}p[100010];
int c[100010];
int lowbit(int k)
{
    return k&(-k);
}
int query(int k)
{
    int sum=0;
    while(k){
        sum+=c[k];
        k-=lowbit(k);
    }
    return sum;
}
void add(int k,int num)
{
    while(k<=n)
    {
        c[k] += num;
        k += lowbit(k);
    }
}
int comp(node &A,node &B)
{
    if(A.x!=B.x) return A.x<B.x;
    else return A.i<B.i;
}

int main()
{

    while(~scanf("%d %d %d",&n,&X,&Y))
    {
        ll sum=0;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&p[i].x);
            p[i].i=i;
        }
        sort(p+1,p+1+n,comp);
        int cnt=1;
        for(int i=1;i<=n;i++)
        {
            add(p[i].i,1);
            sum += (i-query(p[i].i));
        }
        printf("%lld\n",min(X*sum,Y*sum));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值