2018暑假第二次多校1010

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 887    Accepted Submission(s): 345


 

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

 

 

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

 

 

Output

For every test case, a single integer representing minimum money to pay.

 

 

Sample Input

 

3 233 666 1 2 3 3 1 666 3 2 1

 

 

Sample Output

 

0 3

题意:给定长度为n的数组,再给定x和y两个值,存在多少逆序对就要收多少乘x,在收之前可以交换相邻的元素,花费y,问最少花费多少钱。

题解:首先可以证明交换相邻元素至多减少一个逆序数,且只要存在逆序数,则必定存在一组相邻元素,交换他们逆序数减一。

故要么全部交换变成完全升序,要么保持不变。答案即为逆序数乘min(x,y),注意开long long。

#include<stdio.h>
#include<string.h>
#define min(a, b) (a<b?a:b)
long long a[1000010],b[1000010],cnt;
void marge(long long a[],long long s,long long m,long long e)//归并排序的合并部分
{
	long long i=s,j=m+1,k=s;
	while(i<=m&&j<=e)
	{
		if(a[i]<=a[j])
			b[k++]=a[i++];
		else
		{
			cnt+=j-k;
			b[k++]=a[j++];
		}
	}
	while(i<=m)
		b[k++]=a[i++];
	while(j<=e)
		b[k++]=a[j++];
	for(long long i=s;i<=e;i++)
		a[i]=b[i];
} 
void mergesort(long long a[],long long s,long long e)//归并排序
{
	if(s<e)
	{
		long long m=(s+e)/2;
		mergesort(a,s,m);
		mergesort(a,m+1,e);
		marge(a,s,m,e);
	}
}
int main()
{
	long long n,mm;
	long long x, y;
	while(scanf("%lld", &mm) != EOF)
	{
		cnt=0;
		scanf("%lld %lld", &x, &y);
		for(long long i=0;i<mm;i++)
			scanf("%lld",a+i);
		mergesort(a,0,mm-1);
		cnt *=min(x, y);
		printf("%lld\n",cnt);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值