1054. The Dominant Color (20)

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24

这题有点丧病, 也怪自己刷题不多, 有一个点总是过不了, 总是超时.
1. 先是用map做的题目, 超时.
2. 再用查表做题目, 超时.
3. 用丧病的求众数的算法, 超时.
4. 最后发现是cin的锅, 遇到大量输入千万别用cin, 记得用scanf关闭cin的同步(推荐关闭cin同步, std::ios::sync_with_stdio(false))

下面列举算法
(map):

#include <iostream>  
#include <map>
using namespace std;

int main()
{
    map<int, int> m;
    int N, M;
    cin >> M >> N;
    int max = 0;
    int first = 0;
    for (int i = 0; i < N; ++i) {
        for (int j = 0; j < M; ++j) {
            int t;
            scanf("%d", &t);
            m[t]++;
            if (m[t] > max) {
                max = m[t];
                first = t;
            }
        }
    }
    cout << first;
    return 0;
}

求众数:

#include <iostream>  
using namespace std;

int main()
{
    std::ios::sync_with_stdio(false); //关闭与stdin的同步
    int N, M;
    cin >> M >> N;
    int candicate=0, x, times = 0;
    for (int i = 0; i < N; ++i) {
        for (int j = 0; j < M; ++j) {
            cin >> x;
            if (times == 0) {
                candicate = x;
                times++;
            } else {
                if (candicate == x)
                    times++;
                else
                    times--;
            }
        }
    }
    cout << candicate << flush;
    return 0;
}

这一题不推荐查表, 要开的数组太大, 导致遍历的速度非常慢.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值