代码练习系列:问题 B Hello World for U

题目描述

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d

e l

l r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出

For each test case, print the input string in the shape of U as specified in the description.

样例输入

helloworld!
样例输出

h !
e d
l l
lowor
提示

#include <stdio.h>
#include <string.h>

int main()
{
    char s[80];
    gets(s);
    int num = strlen(s);
    int n1,n2,mid;
    n1 = n2 = (num + 2) / 3;
    mid = num - 2 * n1;

    for(int i = 0;i < n1;i++){
        printf("%c",s[i]);
        if(i == n1 - 1){
            for(int k = 0;k < mid;k++){
                printf("%c",s[n1 + k]);
            }
        }else{
            for(int j = 0;j < mid;j++){
                printf(" ");
            }           
        }
        printf("%c\n",s[num - 1 - i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值