1122 Hamiltonian Cycle (25分) 图 模拟

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

 吾:

#include <iostream>
#include <vector>
#include <set>

using namespace std;
const int maxn = 206;

int e[maxn][maxn];

int n;

void check()
{
	int t, pre, now;
	cin >> t;
	vector<int> v;
	set<int> s;
	
	bool flag = false;

	//bool have[maxn] = { false }; 不能用bool数组,因为开头和结尾是同一个点,这样没法区分是重复值还是闭环了,除非最后一个点单独输入,这样太麻烦了,用set集合吧,stl
	for (int i = 0; i < t; i++)
	{
		if (i == 0)
		{
			cin >> pre;
			v.push_back(pre);
			s.insert(pre);
			continue;
		}
		cin >> now;		
		if (e[pre][now] != 1)
		{		
			flag = true;
		}
		pre = now;
		v.push_back(pre);
		s.insert(pre);
	}
	if (flag|| t != n + 1 || s.size() != n|| v[0] != *(v.rbegin()))
	{//依次为四种情况:1.某点到下个点不通;2.点数量不一致;3.有的点不在环里;4.开头和结尾不一致。
		cout << "NO" << endl;
		return;
	}
	
	cout << "YES" << endl;
	return;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int m, k;
	cin >> n >> m;
	for (int i = 0; i < m; i++)
	{
		int a, b;
		cin >> a >> b;
		e[a][b] = e[b][a] = 1;
	}
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		check();
	}

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值