1098 Insertion or Heap Sort (25分) 快速排序 堆排序

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

 吾:

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

vector<int> a, b;
int n;

void shaixuan(vector<int> &b, int start, int end)
{
	int i = 1, j = i * 2;
	while (j<=end)
	{
		if (j+1<=end)//必须有这个if语句,不然会将已经交换过的堆首元素再次考虑其中来进行堆调整,而堆首元素在和堆尾元素交换后是不计入接下来的堆调整的
		{
			j = b[j] > b[j + 1] ? j : j + 1;
		}
		
		if (b[i]<b[j])
		{
			swap(b[j], b[i]);
		}
		i = j;
		j = i * 2;
	}
}

//void shaixuan(vector<int> &b, int low, int high)
//{
//	int i = 1, j = i * 2;
//	while (j<=high)
//	{
//		if (j+1<=high&&b[j]<b[j+1])
//		{
//			j = j + 1;
//		}
//		if (b[i]>=b[j])
//		{
//			break;
//		}
//		swap(b[i], b[j]);
//		i = j;
//		j = i * 2;
//	}
//}

int main()
{
	//freopen("in.txt", "r", stdin);
	cin >> n;
	a.resize(n + 1), b.resize(n + 1);
	for (int i = 1; i <= n; i++)
	{
		cin >> a[i];
	}
	for (int i = 1; i <= n; i++)
	{
		cin >> b[i];
	}
	int p = 1;
	while (p+1<=n&&b[p]<=b[p+1])
	{
		p++;
	}
	p++;//找到第一个不是从小到大排列的数后,还得再往后来一个数,因为要输出下一步的排序结果。
	int t = p;
	
	while (p<=n&&a[p]==b[p])
	{
		p++;
	}
	if (p==n+1)
	{
		cout << "Insertion Sort" << endl;
		sort(b.begin() + 1, b.begin() + t + 1);
	}
	else
	{
		cout << "Heap Sort" << endl;
		p = n;
		while (p>=1&&b[p]>=b[1])
		{
			p--;
		}
		swap(b[p], b[1]);//堆首和堆尾元素互换
		shaixuan(b, 1, p - 1);//互换后,要将前p-1个元素调整为堆。也叫筛选法 课本p342
	}
	cout << b[1];
	for (int i = 2; i < b.size(); i++)
	{
		cout << " " << b[i];
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值