1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​(≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

 本来我自己写的程序 如下: (但是最后一个测试点不过  说运行超时)

#include <iostream>
#include <map>
#include <set>	
#include <string>	
#include <algorithm>

using namespace std;

bool cmp(int a, int b)
{
	return a < b;
}



int main()
{
	//freopen("in.txt", "r", stdin);
	int n, courseTotalNumber;
	cin >> n >> courseTotalNumber;
	map<string, set<int>> m;
	for (int i = 0; i < courseTotalNumber; i++)
	{
		int courseNumber, n;
		string name;
		cin >> courseNumber >> n;
		for (int i = 0; i < n; i++)
		{
			cin >> name;
			
			m[name].insert(courseNumber);
		}
	}
	/*auto map_it = m.cbegin();  //不用给set进行排序 输出直接就是升序
	while (map_it!=m.cend())
	{
		sort(map_it->second.begin(), map_it->second.end(),cmp);
		++map_it;
	}*/
	string query;
	for (int i = 0; i < n; i++)
	{
		cin >> query;
		
		m.find(query);
		cout << query <<" "<<m[query].size();
		for (auto i:m[query])
		{
			cout << " " << i;
		}
		cout << endl;
	}
	//fclose(stdin);
	return 0;
}

然后看了柳婼的代码  她觉得 因为是string 输入输出的时候会超时  所以用了hash

我就改动了一下我自己的代码    也用hash:

#include <iostream>
#include <map>
#include <set>	
#include <string>	
#include <algorithm>

using namespace std;

bool cmp(int a, int b)
{
	return a < b;
}

int getid(string  name) {
	int id = 0;
	for (int i = 0; i < 3; i++)
		id = 26 * id + (name[i] - 'A');
	id = id * 10 + (name[3] - '0');
	return id;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, courseTotalNumber;
	cin >> n >> courseTotalNumber;
	map<int, set<int>> m;   //因为用hash 把string 映射为int 所以map 的keyword类型也改成了int
	for (int i = 0; i < courseTotalNumber; i++)
	{
		int courseNumber, n;
		string temp_name;
		cin >> courseNumber >> n;
		for (int i = 0; i < n; i++)
		{
			cin >> temp_name;
			int name = getid(temp_name);
			m[name].insert(courseNumber);
		}
	}
	/*auto map_it = m.cbegin();  //不用给set进行排序 输出直接就是升序
	while (map_it!=m.cend())
	{
		sort(map_it->second.begin(), map_it->second.end(),cmp);
		++map_it;
	}*/
	string temp_query;
	for (int i = 0; i < n; i++)
	{
		cin >> temp_query;
		int query = getid(temp_query);
		m.find(query);
		cout << temp_query <<" "<<m[query].size();
		for (auto i:m[query])
		{
			cout << " " << i;
		}
		cout << endl;
	}
	//fclose(stdin);
	return 0;
}

 结果自然测试点全对了:

 

 然后我想回过来把之前最后一个测试点不过的代码提交结果截个图  以后复盘 好有全过程      结果发现本来最后一个测试点不过的代码 又过了:

再提交一次:

 其实相同的代码 每次跑  用的时间、内存可能是不一样的    (我个人认为就像打斯诺克     世界上不会有两局 所有球的位置都是一样的  哪怕是开球)

又提交多次  全过   所以就这样吧 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值