poj 1328 贪心

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28579 Accepted: 6263

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


//

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
struct ran
{
    double l;
    double r;
    ran(){l=0,r=0;}
};
int comp(const void *a,const void *b)
{
    return (*(ran *)a).l>(*(ran *)b).l?1:-1;
}
int main ()
{
    //coo c[1001]=new coo[1001];
    ran r[1001];
    int n,d;
    int cnt=1; int flag=0; int ans=0;
    while(scanf("%d%d",&n,&d)==2&&(n||d))
    {
        int x,y; flag=1;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            if(d<=0||d<y) flag=0;
            if(d>=y)r[i].l=x-sqrt(double(d*d-y*y));
            if(d>=y)r[i].r=x+sqrt(double(d*d-y*y));
        }
        if(!flag) ans=-1;
        else{
        qsort(r,n,sizeof(r[0]),comp);
        //for(int i=0;i<n;i++) cout<<r[i].l<<"   "<<r[i].r<<endl;
        ans=0; double min=0;
        for(int i=0;i<n;i++)                                             //区间重叠的贪心算法
        {
            int j=i+1; min=r[i].r;
            ans++;
            while(r[j].l<=min) {if(r[j].r<=min) min=r[j].r;j++; }
            i=j-1;
        }
        }
        cout<<"Case "<<cnt++<<": "<<ans<<endl;
    }
    return 0;
}

//测试数据

2 5
-3 4
-6 3


4 5
-5 3
-3 5
2 3
3 3

20 8
-20 7
-18 6
-5 8
-21 8
-15 7
-17 5
-1 5
-2 3
-9 6
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 7
9 6
10 5
0 0

2 3
0 2
2 3

2 3
0 2
1 3

3 3
1 2
-3 2
2 4

8 5
2 4
-4 4
-3 3
-3 1
-3 0
-1 0
0 5
6 0

3 0
1 2
-3 1
2 1

3 2
1 2
-3 1
2 1

1 2
0 2


2 3
0 2
2 3

4 -5
4 3
4 3
2 3
6 -9



3 -3
1 2
-3 2
2 1

6 2
1 2
1 2
1 2
-3 1
2 1
0 0

1 2
0 2

2 3
0 2
1 3

3 10
1 10
2 3
4 5

3 5
1 10
2 3
4 5

4 7
1 10
2 3
4 5
0 0

3 9
1 10
2 3
4 5
0 0

================结果
Case 1: 1
Case 2: 2
Case 3: 4
Case 4: 1
Case 5: 1
Case 6: -1
Case 7: 3
Case 8: -1
Case 9: 2
Case 10: 1
Case 11: 1
Case 12: -1
Case 13: -1
Case 14: 2
Case 15: 1
Case 16: 1
Case 17: 1
Case 18: -1
Case 19: -1
Case 20: -1
挥着翅膀的鳖 献上。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值