** 动态规划(2) 编程题#2: Charm Bracelet(Coursera 程序设计与算法 专项课程4;#define maxN 3402 此处没有 ; 号!)

编程题#2: Charm Bracelet

来源: POJ (http://bailian.openjudge.cn/practice/4131/)

注意: 总时间限制: 1000ms 内存限制: 65536kB

描述
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a ‘desirability’ factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入
Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23

解题思路:
dd大牛的背包九讲(第一讲 01背包问题)http://blog.csdn.net/happyygdx/article/details/79126439
http://blog.csdn.net/iamiman/article/details/53698222

程序解答:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

#define maxN 3402   //注:此处没有 ; 号!
#define maxM 12880

int main(){
    int N, M, W[maxN + 1], D[maxN + 1];
    int f[maxM + 1];
    cin >> N >> M;
    for (int i = 1; i <= N; i++)
        cin >> W[i] >> D[i];
    memset(f, 0, sizeof(f));

    for (int i = 1; i <= N; i++){
        for (int j = M; j >= W[i]; j--)
            f[j] = max(f[j], f[j - W[i]] + D[i]);
    }

    cout << f[M] << endl;

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值