HDU 1695-GCD(莫比乌斯反演)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12440    Accepted Submission(s): 4702


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

Source
 

Recommend

题意:和BZOJ2301差不多,唯一的区别便是这道题的下限是固定为1的,故简单了许多。。
并且这道题的数据不大,可以不用考虑分块,但有一点需要注意的是(5,7)和(7,5)属于一种情况
故需要简单的容斥一下。。。  当然这道题可以考虑用分块优化。

#include<map>     
#include<stack>            
#include<queue>            
#include<vector>    
#include<string>  
#include<math.h>            
#include<stdio.h>            
#include<iostream>            
#include<string.h>            
#include<stdlib.h>    
#include<algorithm>   
#include<functional>    
using namespace std;
typedef long long  ll;
#define inf  1000000000       
#define mod 1000000007             
#define maxn  160050  
#define lowbit(x) (x&-x)            
#define eps 1e-9  
ll a[maxn] = { 1,1 }, b[maxn], mu[maxn], cnt;
void init()
{
	ll i, j;mu[1] = 1;
	for (i = 2;i<maxn;i++)
	{
		if (a[i] == 0)
			b[++cnt] = i, mu[i] = -1;
		for (j = 1;j <= cnt && i*b[j] <= maxn;j++)
		{
			a[b[j] * i] = 1;
			if (i%b[j] == 0)
			{
				mu[b[j] * i] = 0;
				break;
			}
			else
				mu[b[j] * i] = -mu[i];
		}
	}
}
int  main(void)
{
	init();
	ll T, i, x, y, xx, yy, k, cases = 0;
	scanf("%lld", &T);
	while (T--)
	{
		scanf("%lld%lld%lld%lld%lld", &x, &y, &xx, &yy, &k);
		if (k == 0)
		{
			printf("Case %lld: 0\n", ++cases);
			continue;
		}
		y /= k;yy /= k;
		ll ans1 = 0, ans2 = 0;
		if (y > yy) swap(y, yy);
		for (i = 1;i <= y;i++)
			ans1 += (ll)mu[i] * (y / i)*(yy / i);
		for (i = 1;i <= y;i++)
			ans2 += (ll)mu[i] * (y / i)*(y / i);
		printf("Case %lld: %lld\n",++cases, ans1-ans2/2);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值