Revenge of Fibonacci(杭电5018)

Revenge of Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 721    Accepted Submission(s): 332


Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
F n = F n-1 + F n-2
with seed values F 1 = 1; F 2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 

Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 

Sample Input
  
  
3 2 3 5 2 3 6 2 2 110
 

Sample Output
  
  
Yes No Yes
#include<stdio.h>
#include<string.h>
int s[10000];
int main()
{
    int n,i,a,b,c,k;
	scanf("%d",&n);
	while(n--)
	{
		memset(s,0,sizeof(s));
	    scanf("%d%d%d",&a,&b,&c);
		if(a==c||b==c)  //本题容易少考虑的情况。
		printf("Yes\n");
		else
		{
			k=0;
		    s[1]=a,s[2]=b;
			for(i=3;;)
			{
			    s[i]=s[i-1]+s[i-2];
				if(s[i]<c)
				{
				   i++;
				}
				if(s[i]==c)
				{
				   k=1;
				   break;
				}
				if(s[i]>c)
				{
				   break;
				}
			}
			if(k==1)
			printf("Yes\n");
			else
			printf("No\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值