Visible Lattice Points(Poj3090)(欧拉函数运用)

Visible Lattice Points
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6167 Accepted: 3674

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source

Greater New York 2006


题意:求给定n,在n*n区域内计算可见点的个数。例如n=1时,(1,0),(0,1),(1,1)这三个点是可见点;n=2时,除了那三个点之外,还有(1,2),(2,1)这两个点,(2,2)这个点被(1,1)遮挡住了;n=3时,除了前面那5个点还有(3,1),(3,2),(1,3),(2,3)这四个点未被遮住,共9个点;n=4时,除了前面9个点之外,还有(4,1),(4,3),(1,4),(3,4)这四个点未被遮住。(4,2)这个点被(2,1)这个点遮住了,因为这俩点也在同一条直线上哦!同理(2,4)也被遮住。 


思路:根据上面的题意,可以发现许多结论,除了(1,1)点之外,得到的可见点都是关于y=x直线对称的,那么我们在求解时,求一半再乘2即可(比如求y=x直线以下的点),再看那些可见点的坐标,有没有发现只要横坐标和纵坐标互质的点就是可见点,如果不少互质的话就会和前面的点在同一条直线上。近而转换成求小于等n且于n互质的个数。就是利用欧拉函数。。。


代码:

#include<stdio.h>
int phi[1001];
int euler(int n)
{
	int i,ans;
	ans=n;
	for(i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
			n/=i;
			ans=ans/i*(i-1);
		}
		while(n%i==0)
		{
			n/=i;
		}
	}
	if(n>1)
	    return ans/n*(n-1);
	return ans;
}
int main()
{
	int test,n,sum,kase=1;
	for(int i=1;i<=1000;i++)
	{
		phi[i]=euler(i);
	}
	scanf("%d",&test);
	while(test--)
	{
		sum=1;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		sum+=phi[i]*2;
		printf("%d %d %d\n",kase++,n,sum);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值