Visible Lattice Points
Description A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points. Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N. Input The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow. Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size. Output For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size. Sample Input Sample Output Source |
题目链接:http://poj.org/problem?id=3090
题意:输入C个N,输出的第一个数为第几组输入的事例(case,从1开始),第二个数为N,第三个数为有效的点数(即与(0,0)有直线相连的点);
思路:通过观察可以发现,如果对应的(x,y)坐标的最大公约数为1,则该点一定与(0,0)点相连,所以题目就变成求有多少个点满足gcd(x,y)==1,进而就可以利用欧拉函数求出结果
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int C,N,cas = 0;
int phi(int x){
int res = x;
for(int i = 2; i * i <= x; i ++){
if(x % i == 0){
res = res / i * (i-1);
while(x % i == 0) x /= i;
}
}
if(x > 1) res = res / x * (x-1);
return res;
}
int main(){
scanf("%d",&C);
while(C --){
scanf("%d",&N);
long long ans = 0;
for(int i = 1; i <= N; i ++){
ans += (long long)phi(i);
}
printf("%d %d %lld\n",++cas,N,ans*2+1);
}
return 0;
}