poj 3090 Visible Lattice Points (欧拉函数)

 

Visible Lattice Points

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7768 Accepted: 4760

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source

Greater New York 2006


题目链接:http://poj.org/problem?id=3090

题意:输入C个N,输出的第一个数为第几组输入的事例(case,从1开始),第二个数为N,第三个数为有效的点数(即与(0,0)有直线相连的点);

思路:通过观察可以发现,如果对应的(x,y)坐标的最大公约数为1,则该点一定与(0,0)点相连,所以题目就变成求有多少个点满足gcd(x,y)==1,进而就可以利用欧拉函数求出结果

代码如下:

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int C,N,cas = 0;

int phi(int x){
    int res = x;
    for(int i = 2; i * i <= x; i ++){
        if(x % i == 0){
            res = res / i * (i-1);
            while(x % i == 0) x /= i;
        }
    }
    if(x > 1) res = res / x * (x-1);
    return res;
}

int main(){
    scanf("%d",&C);
    while(C --){
        scanf("%d",&N);
        long long ans = 0;
        for(int i = 1; i <= N; i ++){
            ans += (long long)phi(i);
        }
        printf("%d %d %lld\n",++cas,N,ans*2+1);
    }
    return 0;
}

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值