POJ2488(A Knight's Journey)(DFS+按字典序输出)

14 篇文章 1 订阅
11 篇文章 0 订阅
A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37150 Accepted: 12594

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
 
题意:判断一个骑士是否能走完整个棋盘上的点,按国际象棋中马的规则走,输出字典序最小的序列~
 
国际象棋盘上点的横坐标是A,B,C,D。。。纵坐标是1,2,3,4。。。
既然要走完所有的点,并且保证当前要走的点是字典序最小的点。所以每次都要从左上角那点开始走
用int s[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1}; 来实现搜索过程,并且
保证输出的是字典序最小的序列~   搜索到的第一路径就是骑士所走的路径。
用path[][0]用来存储路径的横坐标,path[][1]来存储路径的纵坐标。
 
#include<stdio.h>
#include<string.h>
int vis[30][30];
int path[30][2];
int s[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};
int a,b,flag;
void dfs(int x,int y,int ans)
{
	if(ans==a*b)
	{
		flag=1;
		for(int i=0;i<ans;i++)
		{
			printf("%c%d",path[i][0]+'A',path[i][1]+1);
		}
		printf("\n");
	}
	for(int i=0;i<8;i++)
	{
		int m=x+s[i][0];
		int n=y+s[i][1];
		if(m>=0&&m<b&&n>=0&&n<a&&!flag&&!vis[m][n])
		{
			vis[m][n]=1;
			path[ans][0]=m;
			path[ans][1]=n;
			dfs(m,n,ans+1);
			vis[m][n]=0;
		}
	}
}
int main()
{
	int test,kase=1;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%d%d",&a,&b);
		memset(vis,0,sizeof(vis));
		memset(path,0,sizeof(path));
		flag=0;
		vis[0][0]=1;
		printf("Scenario #%d:\n",kase++);
		dfs(0,0,1);
		if(!flag) printf("impossible\n");
		printf("\n");
	}
 } 

 
用java语言实现上述过程,思想和代码基本上一样,就是换一下输入输出和一些格式~
 
import java.util.Scanner;
public class Main {

	private static int[][] a = { { -2, -1 }, 
									{ -2, 1 }, 
									{ -1, -2 }, 
									{ -1, 2 }, 
									{ 1, -2 }, 
									{ 1, 2 }, 
									{ 2, -1 },
									{ 2, 1 } }; 

	private static int[][] hang=new int[30][2];
	private static Boolean[][] visit=new Boolean[30][30];
	private static int x,y;  
	private static Boolean flag;


	public static void main(String[] args) {
		
		
		Scanner s = new Scanner(System.in);
		int num=s.nextInt();
		int key=1;
		while (num-->0) {
				flag=false;
				 x=s.nextInt();
				 y=s.nextInt();
				 System.out.println("Scenario #"+key+++":");
				 for (int i = 0; i < 30; i++) {
					for (int j = 0; j < 30; j++) {
						visit[i][j]=false;
					}
				}
		        hang[0][0]=0;
				hang[0][1]=0;
				visit[0][0]=true;
				dfs(0,0,1);
				if (!flag) {
					System.out.println("impossible");
				}
				//System.out.println();
				if(num!=0){
					System.out.println();
				}
		}

	}	
	public static void dfs(int m,int n,int step){
		
		if(step==x*y){
			flag=true;
			for(int i=0;i<step;i++){
				System.out.print((char)(hang[i][0]+'A'));
				System.out.print(hang[i][1]+1);
			}
			System.out.println();
		}
		
		for(int i=0;i<8;i++){
				
			int h=m+a[i][0];
			int l=n+a[i][1];
			if(h<y&&h>=0&&l>=0&&l<x&&!flag&&!visit[h][l]){
				hang[step][0]=h;
				hang[step][1]=l;
				visit[h][l]=true;
				dfs(h,l,step+1);
				visit[h][l]=false;
			}
			
		}
		
	}
	
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值