nyoj.484 The Famous Clock【水题】 2015/03/15

The Famous Clock

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

Mr. B, Mr. G and Mr. M are now in Warsaw, Poland, for the 2012’s ACM-ICPC World Finals Contest. They’ve decided to take a 5 hours training every day before the contest. Also, they plan to start training at 10:00 each day since the World Final Contest will do so. The scenery in Warsaw is so attractive that Mr. B would always like to take a walk outside for a while after breakfast. However, Mr. B have to go back before training starts, otherwise his teammates will be annoyed. Here is a problem: Mr. B does not have a watch. In order to know the exact time, he has bought a new watch in Warsaw, but all the numbers on that watch are represented in Roman Numerals. Mr. B cannot understand such kind of numbers. Can you translate for him?

输入
Each test case contains a single line indicating a Roman Numerals that to be translated. All the numbers can be found on clocks. That is, each number in the input represents an integer between 1 and 12. Roman Numerals are expressed by strings consisting of uppercase ‘I’, ‘V’ and ‘X’. See the sample input for further information.
输出
For each test case, display a single line containing a decimal number corresponding to the given Roman Numerals.
样例输入
I
II
III
IV
V
VI
VII
VIII
IX
X
XI
XII
样例输出
Case 1: 1
Case 2: 2
Case 3: 3
Case 4: 4
Case 5: 5
Case 6: 6
Case 7: 7
Case 8: 8
Case 9: 9
Case 10: 10
Case 11: 11
Case 12: 12
 
#include<stdio.h>
#include<string.h>
int main(){
	int t = 1;
	char s[10];
	while(scanf("%s",s)!=EOF){
		printf("Case %d: ",t++);
		if( strcmp(s,"I") == 0 )
			printf("1\n");
		else if( strcmp(s,"II") == 0 )
			printf("2\n");
		else if( strcmp(s,"III") == 0 )
			printf("3\n");
		else if( strcmp(s,"IV") == 0 )
			printf("4\n");
		else if( strcmp(s,"V") == 0 )
			printf("5\n");
		else if( strcmp(s,"VI") == 0 )
			printf("6\n");
		else if( strcmp(s,"VII") == 0 )
			printf("7\n");
		else if( strcmp(s,"VIII") == 0 )
			printf("8\n");
		else if( strcmp(s,"IX") == 0 )
			printf("9\n");
		else if( strcmp(s,"X") == 0 )
			printf("10\n");
		else if( strcmp(s,"XI") == 0 )
			printf("11\n");
		else if( strcmp(s,"XII") == 0 )
			printf("12\n");
	}
	return 0;
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值