ZOJ.1871 Steps【水,”英语题“】 2015/09/22

Steps

Time Limit: 2 Seconds      Memory Limit: 65536 KB

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.


Input

For each test case, a line follows with two integers: 0 <= x <= y < 2^31.


Output

For each test case, print a line giving the minimum number of steps to get from x to y.


Sample Input

45 48
45 49
45 50


Sample Output

3
3
4


Source: University of Waterloo Local Contest 2000.01.29
题意:从x走到y,第一步和最后一步必须是1,其他的可以比它前一步多走一步、少走一步、或者一样步,求最少要走多少次

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int main(){
    int from,to;
    while( ~scanf("%d%d",&from,&to) ){
        int dis = to - from;
        if( !dis ){
            printf("0\n");
            continue;
        }
        int x = 0,i,step;
        for( i = 1 ; ; ++i ){
            if( x + i * 2 >= dis ) break;
            x += i*2;
        }
        step = i*2-2;
        if( x+i*2 == dis )
            printf("%d\n",step+2);
        else if( x+i >= dis )
            printf("%d\n",step+1);
        else printf("%d\n",step+2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值