HDOJ 5655-CA Loves Stick【思维题】

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2323    Accepted Submission(s): 666


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains T denoting the number of testcases.
T testcases follow. Each testcase contains four integers a,b,c,d in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 

Source
解题思路:
题目的意思就是给你四个长度,看看是否能够摆成矩形。方法就是任意三边之和大于第四边,注意三边只和会大于ll。还有零的情况。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		bool xx=0;
		long long x[4];
		for(int i=0;i<4;i++){
			scanf("%lld",&x[i]);
			if(x[i]==0)
			xx=1;
		}
		if(xx){
			printf("No\n");
			continue;
		}
		sort(x,x+4);
		if(x[0]>(x[3]-x[2]-x[1]))
		printf("Yes\n");
		else
		printf("No\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值