ACM/ICPC 2018亚洲区预选赛北京赛站网络赛 A Saving Tang Monk II 【分层搜索】

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

'S' : The original position of Sun Wukong

'T' : The location of Tang Monk

'.' : An empty room

'#' : A deadly gas room.

'B' : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a 'B' room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

'P' : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a 'P' room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn't get into a '#' room(deadly gas room) without an oxygen bottle. Entering a '#' room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a '#' room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.

输入

There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.

输出

For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print -1

样例输入

2 2
S#
#T
2 5
SB###
##P#T
4 7
SP.....
P#.....
......#
B...##T
0 0

样例输出

-1
8
11
#include<bits/stdc++.h>
using namespace std;
int n, m;
int Step[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};
string a[200];
struct node{
    int x, y, step, med;
    bool operator < (const node &a) const{
        return step > a.step;
    }
} op, uv;
int vis[200][200][10];
void bfs(int nx, int ny){
    priority_queue <node> q;
    memset(vis, 0, sizeof vis);
    op.x = nx, op.y = ny, op.step = 0, op.med = 0;
    vis[nx][ny][0] = 1;
    q.push(op);
    while(!q.empty()){
        op = q.top();
        if(a[op.x][op.y] == 'T'){
            cout << op.step << endl;
            return;
        }
        q.pop();
        for(int i = 0; i < 4; i++){
            uv = op;
            uv.x += Step[i][0];
            uv.y += Step[i][1];
            if(uv.x >= 0 && uv.y >= 0 && uv.x < n && uv.y < m){
                uv.step++;
                if(a[uv.x][uv.y] == '#'){
                    if(!uv.med) continue;
                    uv.med--;
                    uv.step++;
                    if(!vis[uv.x][uv.y][uv.med]) q.push(uv), vis[uv.x][uv.y][uv.med] = 1;
                }
                else if(a[uv.x][uv.y] == 'B'){
                    uv.med = min(5, uv.med + 1);
                    if(!vis[uv.x][uv.y][uv.med]) q.push(uv), vis[uv.x][uv.y][uv.med] = 1;
                }
                else if(a[uv.x][uv.y] == 'P'){
                    uv.step--;
                    if(!vis[uv.x][uv.y][uv.med]) q.push(uv), vis[uv.x][uv.y][uv.med] = 1;
                }
                else{
                    if(!vis[uv.x][uv.y][uv.med]) q.push(uv), vis[uv.x][uv.y][uv.med] = 1;
                }
            }
        }
    }
    cout << "-1" << endl;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0), cout.tie(0);
    while(cin >> n >> m){
        if(n == 0 && m == 0) break;
        int x, y;
        for(int i = 0; i < n; i++){
            cin >> a[i];
            for(int j = 0; j < m; j++){
                if(a[i][j] == 'S') x = i, y = j;
            }
        }
        bfs(x, y);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值