hdu1061 Rightmost Digit 快速幂的简单应用

**Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
**

题意:求n的n次方最右边的数,也就是最后一个数字。
思路:由于数值n的范围很大,不能用寻常套路写这道题,这道题的正解是快速幂取模运算的应用,基于公式:
(a*b)%c=(a%c*b%c)%c
(话说第一次WA就是因为取模出错,导致范围超了)

#include<stdio.h>
int f(int m,int n)
{
    if( n == 1)
        return m;
    long long s = f(m,n/2)%10;
    if( n%2 == 1)
        return (s*s*m)%10;
    else
        return (s*s)%10;
}

int main()
{
    int n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",f(n,n));
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值