hdu 1017 A Mathematical Curiosity

**Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input
1

10 1
20 3
30 4
0 0

Sample Output
Case 1: 2
Case 2: 4
Case 3: 5
**

题意:t组样例,每组样例输入n和m,1:以n=m=0作为每组样例的结束,每组样例之间输出空行,输出在n范围内,满足 0 < a < b < n 和 (a^2+b^2 +m)/(ab)为整数的数对总数。

#include<stdio.h>

int main()
{
    int t,m,n,i,j,count,sum;
    scanf("%d",&t);
    for(int k= 0;k < t;k++)
    {
        sum = 0;
        if(k != 0)
            printf("\n");
        while(scanf("%d%d",&n,&m),n!=0||m!=0)
        {
            count = 0;

            sum ++;
            for(i = 1; i < n; i ++)
                for(j = 1; j < n; j ++)
                {
                    if((i*i+j*j+m)% (i*j) == 0&&i<j)
                         count ++;
                }
            printf("Case %d: %d\n",sum,count);
        }
    }
    return 0;
}

后记:这道题 自己没翻译到‘样例间有空行’这句话;忘记了while语句内是循环条件,而不是跳出条件;漏写a < b这一判断条件。所以自己WA了4遍,PE一遍。这只是一次c语言作业题,很多没参加竞赛的人是一遍a的,再不刷题,到时候自己连水题都写不动了。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值