HDU__1002A + B Problem II(大数加法)

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.





Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.





Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.





Sample Input

2
1 2
112233445566778899 998877665544332211





Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


注意事项都在代码里注释了,还是爱犯很多小毛病

 #include<iostream>
 #include<string>
 #include<cstdio>
 #include<vector>
 #include<algorithm>
 using namespace std;
 int main()
 {
 	int t,putcnt = 0;
 	string s1,s2;
 	vector<int> a,b,c;
 	cin>>t;
 	while(t--)
 	{
 		cin>>s1>>s2;
// 		a.clear();
// 		b.clear();
// 		c.clear();//清空后并没有自动赋值为0!! 
 		//逆序 ——并没有实现逆序!!! 
 		for(int i = s1.size() - 1; i >= 0;i--)
 		{
 			a.push_back(s1[i] - '0');
		}
//		for(int i = 0; i < a.size();i++)
//		{
//			cout<<a[i];
//		 } 
 		for(int i = s2.size() - 1; i >= 0;i--)
 		{
 			b.push_back(s2[i] - '0');
		}
//		cout<<endl;
//		for(int i = 0; i < b.size();i++)
//		{
//			cout<<b[i];
//		 } 
 		//相加到s3 
		int is_jin = 0,push;
		int lenmax = max(a.size(),b.size());
		for(int i = 0;i < lenmax;i++)
		{
			if(i >= a.size())//补位操作 
			{
				a.push_back(0);
			}
			if(i >= b.size())
			{
				b.push_back(0);
			}
			
			push = (a[i] + b[i] + is_jin) % 10;
			c.push_back(push);
			is_jin = (a[i] + b[i] + is_jin) / 10;
			
			
		}
		if(is_jin)
		{
			c.push_back(1);
		}
		// 输出
		printf("Case %d:\n",++putcnt);
		cout<<s1<<" + "<<s2<<" = ";//string只支持cin和cout不能用scanf和printf 
		for(int i = c.size() - 1;i >= 0;i--)
		{
			cout<<c[i];
		} 
 		cout<<"\n";//注意输出格式 
 		if(t >= 1)
		 {
		 	cout<<endl;
		  } //尾部虽然都要求空一个空行,但是不能空两个啊!!~~注意输出格式,好好理解题目吧 
 		a.clear();
 		b.clear();
 		c.clear();
 		s1.clear();
 		s2.clear();
 		
	 }
 	
 	
 	
 	return 0;
  } 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值