【背包专题】K - WHUgirls hdu3127 【二维完全背包】

72 篇文章 0 订阅
40 篇文章 0 订阅
There are many pretty girls in Wuhan University, and as we know, every girl loves pretty clothes, so do they. One day some of them got a huge rectangular cloth and they want to cut it into small rectangular pieces to make scarves. But different girls like different style, and they voted each style a price wrote down on a list. They have a machine which can cut one cloth into exactly two smaller rectangular pieces horizontally or vertically, and ask you to use this machine to cut the original huge cloth into pieces appeared in the list. Girls wish to get the highest profit from the small pieces after cutting, so you need to find out a best cutting strategy. You are free to make as many scarves of a given style as you wish, or none if desired. Of course, the girls do not require you to use all the cloth.

InputThe first line of input consists of an integer T, indicating the number of test cases. 
The first line of each case consists of three integers N, X, Y, N indicating there are N kinds of rectangular that you can cut in and made to scarves; X, Y indicating the dimension of the original cloth. The next N lines, each line consists of two integers, xi, yi, ci, indicating the dimension and the price of the ith rectangular piece cloth you can cut in. 
OutputOutput the maximum sum of prices that you can get on a single line for each case. 

Constrains 
0 < T <= 20 
0 <= N <= 10; 0 < X, Y <= 1000 
0 < xi <= X; 0 < yi <= Y; 0 <= ci <= 1000 
Sample Input

1
2 4 4
2 2 2
3 3 9

Sample Output

9

题意:给定一个x*y的矩形,输入n块xi*yi的小矩形,价值为value[i],问分割矩形为小矩形后能够得到的最大价值。
思路:这道题给定矩形是无序的,我们并不确定哪个小矩形作为第一个从大矩形中分割出去能够得到最大价值,所以把小矩形长宽作为外循环,矩形序号作为内循环。在比较最优值时我们加上判断条件,因为总共分为两类情况,两类情况里又分为两种分割方式。
假设小矩形长为x[i],宽为y[i],价值为value[i]。
第一种情况:矩形长和宽大于等于小矩形长和宽即 x>=x[i]&&y>=y[i]。
第一种分割方式:dp[x[i]][k-y[i]]+dp[j-x[i]][k]+value[i]
第二种分割方式:dp[j-x[i]][y[i]]+dp[j][k-y[i]]+value[i]

第二种情况:矩形的长和宽大于等于小矩形的宽和长即 x>=y[i]&&y>=x[i]
第一种分割方式:dp[j][k-x[i]]+dp[j-y[i]][x[i]]+value[i]
第二种分割方式:dp[j-y[i]][k]+dp[y[i]][k-x[i]]+value[i]
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1010
int dp[N][N],x[20],y[20],value[20];

int main()
{
    int t,n,X,Y,i,j,k;
    scanf("%d",&t);
    while( t--)
    {
        scanf("%d%d%d",&n,&X,&Y);
        memset(dp,0,sizeof(dp));
        for(i = 1; i <= n; i ++)
            scanf("%d%d%d",&x[i],&y[i],&value[i]);
        for(j = 0; j <= X; j ++)
            for(k = 0; k <= Y; k ++)
                for(i = 1; i <= n; i ++)
                {
                    if(j >= x[i]&&k >= y[i])//第一种情况
                        dp[j][k] = max(dp[j][k],max(dp[x[i]][k-y[i]]+dp[j-x[i]][k],dp[j-x[i]][y[i]]+dp[j][k-y[i]])+value[i]);
                    if(j >= y[i]&&k >= x[i])//第二种情况
                        dp[j][k] = max(dp[j][k],max(dp[j][k-x[i]]+dp[j-y[i]][x[i]],dp[j-y[i]][k]+dp[y[i]][k-x[i]])+value[i]);
                }
        printf("%d\n",dp[X][Y]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值