hdu 5532【最长非递增子序列 时间复杂度 nlogn】

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 6044    Accepted Submission(s): 1451


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an , is it almost sorted?
 

Input
The first line contains an integer  T  indicating the total number of test cases. Each test case starts with an integer  n  in one line, then one line with  n  integers  a1,a2,,an .

1T2000
2n105
1ai105
There are at most 20 test cases with  n>1000 .
 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

Sample Output
  
  
YES YES NO
 

Source
 


题意:由n个数组成的序列,如果去掉一个数后仍保持非递增或者非递减,则输出YES,否则输出NO.

思路:只需要求最长非递增子序列的长度和最长非递减子序列的长度,如果其中一个长度+1>=n,说明可以实现。(注意:用O(n*n)的算法会导致tle,此处用的是O(nlogn)的算法)

#include<stdio.h>
#define N 100010

int num[N],end1[N],end2[N];

int find1(int flag,int *end,int low,int high)
{//end1数组按非递减顺序存储每一位的最小值 
    int mid;
    while(low < high)
    {
        mid = (low+high)>>1;
        if(end[mid] > flag)
            high = mid;
        else
            low = mid + 1;
    }
    return low;
}

int find2(int flag,int *end,int low,int high)
{//end2数组按非递增顺序存储每一位的最大值 
    int mid;
    while(low < high)
    {
        mid = (low+high)>>1;
        if(end[mid] >= flag)
            low = mid+1;
        else
            high = mid;
    }
    return low;
}

int main()
{
    int t,n,i,j,ans,len1,len2;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 1; i <= n; i ++)
            scanf("%d",&num[i]);
        end1[1] = end2[1] = num[1];
        len1 = len2= 1;
        for(i = 2; i <= n; i ++)
        {
            if(num[i] >= end1[len1])//最长非递减 
                ans = ++len1;
            else
                ans = find1(num[i],end1,1,len1+1);
            end1[ans] = num[i]; 
            
            if(num[i] <= end2[len2])//最长非递增 
                ans = ++len2;
            else
                ans = find2(num[i],end2,1,len2+1);
            end2[ans] = num[i];
        }
        if(len1 + 1== n||len2 + 1== n||len1==n||len2==n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值