poj 3009 Curling 2.0 【dfs】

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1
题意:输出从2开始到3结束的最小步数,超过10步或者无法到达终点输出-1。行走规则,1表示墙,0表示能通过,从开始往一个方向走,只有撞到墙才能调转方向,即步数+1,且撞到墙后,墙1变为0。

思路:dfs+回溯,从开始位置向四个方向搜索,直到遇到墙或者越界才停止往该方向搜索,如果在搜索期间遇到了终点,停止往下搜索,判断停止时的坐标是否越界或者是否是该方向i无法通过,如果是,终止此次循环,开始下一次循环,如果不是,将撞到的墙的坐标标记为0,表示能通过,由于我们并不确定该方向是否能够找到终点,所以需要回溯。

#include<stdio.h>
#include<string.h>
int m,n,sx,sy;
int max ;
int map[25][25],flag;
void dfs(int x,int y,int step)
{
	int k[4][2] = {1,0,-1,0,0,-1,0,1};
	int nx,ny;
	if(map[x][y] == 3)
	{
		flag = 1;
		if(step < max)
			max = step;//到达终点时取值较小 
		return;
	}
	if(step >= 10||step >= max)
		return ;//如果超过既定步数或者这条路超过最小步数,停止搜索 
	for(int i = 0; i < 4; i ++)   //搜索四个方向                                           
	{
		nx = x + k[i][0];
		ny = y + k[i][1];
		while(1)//一直往一个方向走 
		{
			if(nx<0||ny < 0||nx >n-1||ny > m-1||map[nx][ny] == 1)
				break;
			if(map[nx][ny] == 3)//如果在行走期间遇到了终点,停止搜索 
			{
				step ++;
				if(step < max)
					max = step;
				flag = 1;
				return;
			}
			nx += k[i][0];
			ny += k[i][1];
		}
		//如果越界或者该方向无法通过 
		if(nx < 0||ny <0||nx > n-1||ny > m-1||(nx == x+k[i][0]&&ny == y+k[i][1])) 
			continue;
		map[nx][ny] = 0;
		step ++;
		dfs(nx-k[i][0],ny-k[i][1],step);//后退一步继续往下搜索 
		map[nx][ny] = 1;//回溯 
		step--;
	}
	return;
}

int main()
{
	int number;
	while(scanf("%d%d",&m,&n),m!=0||n!=0)
	{
		for(int i = 0; i < n; i ++)
			for(int j = 0; j < m; j ++)
			{
				scanf("%d",&number);
				map[i][j] = number;
				if(number == 2)
				{
					sx = i;
					sy = j;
					map[i][j] = 0;
				}
			}
		flag = 0;
		max = 0x3f3f3f3f;
		dfs(sx,sy,0);
		if(flag)
			printf("%d\n",max);
		else
			printf("-1\n"); 
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值