hdu 3371 Connect the cities【最小生成树】

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

Input The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
Output For each case, output the least money you need to take, if it’s impossible, just output -1. Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
Sample Output
1

题意:给定顶点和每条边的权值,再输入k行,每行输入一个数t,再输入t个数,表示这t个顶点已经相互连通,求最小生成树的权值。

思路:在最小生成树的基础上,只需要做一个小小的变化,将已连通顶点的边权值置为0即可,注意一个坑点,输入会有重边,取权值最小。

用了prime和Kruskal 都试过了,Kruskal超时,记住 稠密图用prime!!!

prime()算法

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
const int maxn = 550;
int vis[maxn][maxn],book[maxn],dis[maxn],num[maxn];
int n,m,k,flag;
int prime()
{
	int i,j,minn,u;
	int sum = 0;
	memset(book,0,sizeof(book));
	for(i = 1; i <= n; i ++)
		dis[i] = vis[1][i];
	book[1] = 1;
	for(i = 1; i < n;  i ++)
	{
		minn = inf;
		for(j = 1; j <= n; j ++)
		{
			if(dis[j] < minn&&!book[j])
			{
				u = j;
				minn = dis[j];
			}
		}
		if(minn == inf)//如果在至少n-1边内出现了最小值等于初始值的情况,说明不满足条件 
			return inf;
		book[u] = 1;
		sum += minn;//求最小权值 
		for(j = 1; j <= n; j ++)
		{
			if(dis[j] > vis[u][j])
				dis[j] = vis[u][j];
		}
	}
	return sum;
}

int main()
{
	int i,j,K,k,t;
	int T;
	int x,y,w;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&K);
		for(i = 1; i <= n; i ++)
			for(j = 1; j <= n; j ++)
				if(i == j)
					vis[i][j] = 0;
				else
					vis[i][j] = inf;
		for(i = 1; i <= m;  i ++)
		{
			scanf("%d%d%d",&x,&y,&w);
			if(vis[x][y]>w)//重边 
			{
				vis[x][y] = w;
				vis[y][x] = w;
			}
		}
		for(i = 1; i <= K; i ++)
		{
			scanf("%d",&t);
			for(j = 1; j <= t; j ++)
				scanf("%d",&num[j]);
			
			for(j = 1; j <= t; j ++)
			{
				for(k = 1; k < j; k ++)
				{
					vis[num[j]][num[k]] = 0;
					vis[num[k]][num[j]] = 0;
				}
			}
		}
		flag = prime();
		if(flag==inf)
			printf("-1\n");
		else
			printf("%d\n",flag);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值