POJ 1328 Radar Installation(预处理贪心)


题目链接:http://poj.org/problem?id=1328

Radar Installation
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 74959
Accepted: 16771

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


题意:有n个岛屿,用雷达半径为d的雷达进行全部覆盖扫描,问最少需要几个雷达,要是无法完成输出-1.

解题思路:这题困了我两天,最后写了一个下午才解决,被d可以为负数坑死,WA了十几发。
    这题实质上是个区间选点问题。1)问题转换,先计算出以每个岛屿为原点,d为半径做圆交与x轴的线段。
                                2)问题转化成,已知n个闭合区间,问至少需要几个点可以将其全部覆盖。
                                3)将线段以右端点right从小到大进行排序,每次选出排序后最靠前的线段,以该线段的右端点为雷达放置位置(end),
                                   一直向右扫描线段,如果找到线段的left大于end,就更新end(自己想想为何),end=新线段.right。
                                4)一直扫描知道结束
注意事项:d可以为负数。

附上AC代码
<span style="background-color: rgb(255, 255, 255);">#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=1001;
struct node{
   double left,right;
}nod[maxn];
bool cmp(node a,node b)
{
   return a.right<b.right;
}
int main()
{
    int n,r,cas=0;
    while(~scanf("%d %d",&n,&r) &&n!=0 && r!=0)
    {
         double x,y,maxy;
         bool flag=false;
         for(int i=0;i<n;i++)
         {
             scanf("%lf %lf",&x,&y);
             if(y>r || r<0){
                flag=true;
             }
             else{
                nod[i].left=x-sqrt(r*r-y*y);
                nod[i].right=x+sqrt(r*r-y*y);
             }
         }
         if(flag){
            printf("Case %d: -1\n",++cas);
            continue;
         }
         sort(nod,nod+n,cmp);
         double end=nod[0].right;
         int ans=1;
         for(int i=1;i<n;i++)
         {
             if(end<nod[i].left){
                ans++;
                end=nod[i].right;
             }
         }
         printf("Case %d: %d\n",++cas,ans);
    }
    return 0;
}

</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值