HDOJ DNA Sorting(第一周)

DNA Sorting

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 3
Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
 

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
 

Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
 

Sample Input
  
  
10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
 

Sample Output
  
  
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA 这道题难点在于读懂题意,题意读懂了,就好做了,这道题的意思是,计算每个字符串中一个字符后面的比他小的字符的个数总和,例如:AACATGAAGG 比第一位小的为0个,同理,第二个也为0个,第三个c有3个,第五个T有5个,第六个G有2个,总和9个,依次求出,然后排序输出。 ac代码:
<pre name="code" class="cpp">#include<stdio.h>  
#include<stdlib.h>  
#include<iostream>  
#include<algorithm>  
#include<string.h>  
using namespace std;  
struct s  
{  
    char cc[1000];  
    int num;  
}str[1000];  
bool cmp(s a, s b)  //按照数量排序  
{    
   return a.num<b.num;    
}  
int main()  
{  
    int n,m,i,k,j;  
    int t;
    scanf("%d",&t);
    while(t--)
    {  
	    scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)    
            {    
                str[i].num=0;    
                scanf("%s",str[i].cc);    
                for(j=0;j<n;j++)    
                for(k=j+1;k<n;k++)    
                {    
                    if(str[i].cc[j]>str[i].cc[k])    
                        str[i].num++;    
                }    
            }  
        sort(str,str+m,cmp);  
        for(i=0;i<m;i++)  
        printf("%s\n",str[i].cc);  
    }  
    return 0;  
}  




 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值