The Triangle
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
4
-
描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.-
输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 输出
- Your program is to write to standard output. The highest sum is written as an integer. 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
样例输出
-
30
题意就是求从最上面一层到最下面一层路径数字相加的最大值,所以从下到上更新较为清楚
ac代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
int a[100][1000];
int i,j,n;
scanf("%d",&n);
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
{
for(j=0;j<=i;j++)
{
scanf("%d",&a[i][j]);
}
}
for(i=n-2;i>=0;i--)//从下到上更新
{
for(j=0;j<i+1;j++)
{
if(a[i+1][j]>a[i+1][j+1])
a[i][j]+=a[i+1][j];
else
a[i][j]+=a[i+1][j+1];
}
}
printf("%d\n",a[0][0]);//最上面的就是最大值
return 0;
}