HDOJ 5459 Jesus Is Here(打表规律)

Jesus Is Here

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/102400 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 290


Problem Description
I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?
``But Jesus is here!" the priest intoned. ``Show me your messages."
Fine, the first message is s1=c" and the second one is s2=ff" .
The i -th message is si=si2+si1 afterwards. Let me give you some examples.
s3=cff" , s4=ffcff" and s5=cffffcff" .

``I found the i -th message's utterly charming," Jesus said.
``Look at the fifth message". s5=cffffcff" and two cff" appear in it.
The distance between the first cff" and the second one we said, is 5 .
``You are right, my friend," Jesus said. ``Love is patient, love is kind.
It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.
Love does not delight in evil but rejoices with the truth.
It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different cff" as substrings of the message.
 

Input
An integer T (1T100) , indicating there are T test cases.
Following T lines, each line contain an integer n (3n201314) , as the identifier of message.
 

Output
The output contains exactly T lines.
Each line contains an integer equaling to:
i<j:sn[i..i+2]=sn[j..j+2]=cff"(ji) mod 530600414,

where sn as a string corresponding to the n -th message.
 

Sample Input
  
  
9 5 6 7 8 113 1205 199312 199401 201314
 

Sample Output
  
  
Case #1: 5 Case #2: 16 Case #3: 88 Case #4: 352 Case #5: 318505405 Case #6: 391786781 Case #7: 133875314 Case #8: 83347132 Case #9: 16520782 开始看就感觉不会那么简单,暴力一写果然超时,应该是规律,但是实 在是没找到,看到别人的规律,秒懂,哎..... ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 210000
#define MOD 530600414
using namespace std;
long long len[MAXN],pos[MAXN],sum[MAXN],num[MAXN];
void db()
{
    len[5]=8;len[6]=13;
    num[5]=2;num[6]=3;
    pos[5]=7;pos[6]=20;
    sum[5]=5;sum[6]=16;
    for(int i=7;i<MAXN;i++)
    {
        len[i]=(len[i-2]+len[i-1])%MOD;
        num[i]=(num[i-2]+num[i-1])%MOD;
        pos[i]=(pos[i-1]+pos[i-2]+(len[i-2]*num[i-1])%MOD)%MOD;
        sum[i]=(sum[i-1]+sum[i-2]+(((len[i-2]*num[i-2]-pos[i-2]))%MOD*num[i-1])%MOD+(pos[i-1]*num[i-2])%MOD)%MOD;
    }
}
int main()
{
    db();
    int t;
    int n;
    int cas=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("Case #%d: %lld\n",++cas,sum[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值