Jesus Is Here HDU - 5459

I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?
``But Jesus is here!" the priest intoned. ``Show me your messages."
Fine, the first message is s1=‘‘c" and the second one is s2=‘‘ff".
The i-th message is si=si−2+si−1 afterwards. Let me give you some examples.
s3=‘‘cff", s4=‘‘ffcff" and s5=‘‘cffffcff".

``I found the i-th message's utterly charming," Jesus said.
``Look at the fifth message". s5=‘‘cffffcff" and two ‘‘cff" appear in it.
The distance between the first ‘‘cff" and the second one we said, is 5.
``You are right, my friend," Jesus said. ``Love is patient, love is kind.
It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.
Love does not delight in evil but rejoices with the truth.
It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different ‘‘cff"
as substrings of the message.
Input
An integer T (1≤T≤100), indicating there are T test cases.
Following T lines, each line contain an integer n (3≤n≤201314)
, as the identifier of message.
Output
The output contains exactly T lines.
Each line contains an integer equaling to:
∑i<j:sn[i..i+2]=sn[j..j+2]=‘‘cff"(j−i) mod 530600414,

where sn as a string corresponding to the n
-th message.
Sample Input

9
5
6
7
8
113
1205
199312
199401
201314

Sample Output

Case #1: 5
Case #2: 16
Case #3: 88
Case #4: 352
Case #5: 318505405
Case #6: 391786781
Case #7: 133875314
Case #8: 83347132

Case #9: 16520782

用f[i]表水第i项字符串中所有c的距离之和。由于第i项是由第i-1和第i-2项得到,f[i]=f[i-1]+f[i-2]+X。而X是第i-2字符串中c到第i-1字符串中c的距离之和。

假设由字符串cffcff和 cffffcfffcff 得到的 cffcfcffffcfffcff。由第i-2项中c分别到第i-1项中c的距离式子得到X为dist[i-2]*cnt[i-1]+(cnt[i-2]*cnt[i-1])*len[i-1]-cnt[i-2]*dist[i-1].

cnt[i]表示第i项中c的个数。dist[i]表示第i项式中所有c到字符串最后的距离之和。len[i]表示字符串长度。


#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
#define maxn 201400
#define mod 530600414
using namespace std;
typedef long long ll;
ll f[maxn];
ll cnt[maxn];//c的个数
ll dis[maxn];//c到结尾的距离和
ll len[maxn];//字符串总长度
void init(){
f[3]=0; f[4]=0;
cnt[3]=1;cnt[4]=1;
dis[3]=2;dis[4]=2;
len[3]=3;len[4]=5;
for(int i=5;i<maxn;i++)
{
    dis[i]=(dis[i-1]%mod+dis[i-2]%mod+cnt[i-2]*len[i-1]%mod)%mod;
    cnt[i]=(cnt[i-1]%mod+cnt[i-2]%mod)%mod;
    len[i]=(len[i-1]%mod+len[i-2]%mod)%mod;
    f[i]=(f[i-1]%mod+f[i-2]%mod+(cnt[i-2]%mod*(len[i-1]%mod*cnt[i-1]%mod))%mod+(cnt[i-1]%mod*dis[i-2]%mod)%mod-(cnt[i-2]%mod*dis[i-1]%mod)%mod)%mod;
}
}
int main()
{
    int t,n;
    scanf("%d",&t);
    int cas=1;
    init();
    while(t--)
    {
        scanf("%d",&n);
        printf("Case #%d: %lld\n",cas++,f[n]);
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值