HDOJ 5504 GT and sequence (乱搞)

60 篇文章 0 订阅
5 篇文章 0 订阅

GT and sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2192    Accepted Submission(s): 504


Problem Description
You are given a sequence of N integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that **the absolute value of** any product of the numbers you choose in the initial sequence will not bigger than 2631 .
 

Input
In the first line there is a number T (test numbers).

For each test,in the first line there is a number N ,and in the next line there are N numbers.

1T1000
1N62

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output the answer.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
6 题意:给出NNN个整数。你要选择至少一个数,使得你选的数的乘积最大。 保证任意选一些数相乘的绝对值都不会大于2^63-1 思路:输入的数包括负数、正数、零,注意负数和0的情况就行了如果负数的个数为,那么除以最大的那个负数就行了 ,如果存在0,不能把0乘入总积,到最后在判断情况就行了。 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define LL long long
#define MAXN 100010
#define INF 0x7fffffff 
using namespace std;
LL a[65];
LL ans;
int main()
{
	int t,i,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		if(n==1)
		{
			scanf("%lld",&a[0]);
			printf("%lld\n",a[0]);
			continue;
		}
		LL k=-INF;
		LL ans=1;
		int cnt=0;
		int bz=0;
		for(i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
			if(a[i]!=0)
			ans*=a[i];
			if(a[i]<0)
			k=max(a[i],k),cnt++;
			else if(a[i]>0)
			bz=1;
		}
		if(cnt<=1&&bz==0)
		{
			printf("0\n");
			continue;
		}
		if(cnt%2)
		{
			ans=ans/k;
			printf("%lld\n",ans);
		}
		else
		printf("%lld\n",ans);
	}
    return 0;
}
提供几组数据:
1000
3
1 1 1
5
1 1 -1 2 2
6
2 -1 -3 -5 1 1
7
0 1 1 1 2 2 1
3
0 -1 1
4
0 -1 -3 4
5
0 0 -3 -1 2
2
0 -1
2
-1 2

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值