杭电-5504GT and sequence

GT and sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2213    Accepted Submission(s): 508


Problem Description
You are given a sequence of N integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that **the absolute value of** any product of the numbers you choose in the initial sequence will not bigger than 2631 .
 

Input
In the first line there is a number T (test numbers).

For each test,in the first line there is a number N ,and in the next line there are N numbers.

1T1000
1N62

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output the answer.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
6
 


给一个数列,选择若干个数,求出其最大乘积



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool cmp(__int64 a,__int64 b)
{
	return a<b;
}
int main()
{
	__int64 a,b,c,i,j,m,n,x[100],y[100],q1,q2,sum;
	
	scanf("%I64d",&m);
	while(m--)
	{
		scanf("%I64d",&n);
		q1=0,q2=0;
		for(i=0;i<n;i++)
		{
			scanf("%I64d",&a);
			if(a>0)
			x[q1++]=a;
			if(a<0)
			y[q2++]=a;
		}
		sort(y,y+q2,cmp);
		
		if(!q1&&!q2)
		{
			printf("0\n");
			continue;
		}
	    if(!q1&&q2==1&&n>1)
	    {
	    	printf("0\n");
	    	continue;
		}
		if(n==1&&q2==1)
	    {
	    	printf("%I64d\n",y[0]);
	    	continue;
		}
		sum=1;
		for(i=0;i<q1;i++)
			sum*=x[i];
			
		if(q2%2==0)
		{
			for(i=0;i<q2;i++)
			sum*=y[i];
		}
		else 
		{
			for(i=0;i<q2-1;i++)
			sum*=y[i];
		}
		printf("%I64d\n",sum);
	}
	return 0;	
 } 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值