HDOJ 5150 Sum Sum Sum (素数和 水)

Sum Sum Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 982    Accepted Submission(s): 578


Problem Description
We call a positive number X P-number if there is not a positive number that is less than X and the greatest common divisor of these two numbers is bigger than 1.
Now you are given a sequence of integers. You task is to calculate the sum of P-numbers of the sequence.
 

Input
There are several test cases.
In each test case:
The first line contains a integer N(1N1000) . The second line contains N integers. Each integer is between 1 and 1000.
 

Output
For each test case, output the sum of P-numbers of the sequence.
 

Sample Input
  
  
3 5 6 7 1 10
 

Sample Output
  
  
12 0
 

题意:n个数,求素数和

思路:水题,直接打表,注意这里1是素数




ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1.0)
using namespace std;
int gcd(int a,int b){return b?gcd(b,a%b):a;}
LL powmod(LL a,LL b,LL MOD){LL ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
//head
int v[MAXN];
void db()
{
	mem(v);
	for(int i=2;i<=1000;i++)
	{
		if(!v[i])
		{
			for(int j=i*2;j<=1000;j+=i)
			v[j]=1;
		}
	}
}
int main()
{
	db();
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int ans=0;
		for(int i=0;i<n;i++)
		{
			int a;
			scanf("%d",&a);
			if(!v[a])
			ans+=a;
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值